如果显示为中文就是:

注意: a.java 使用了未经检查或不安全的操作。

注意: 要了解详细信息,请使用 -Xlint:unchecked 重新编译。

其实是很简单,是因为用到了JAVA5.0的泛型,而5.0的泛型不做类型检查,例如ArrayList a =new ArrayList();

a.add("hello");这样会出现警告,解决方法有以下几种:

1)在方法的前面加上@SuppressWarnings("unchecked")

2)声明泛型类型,例如ArrayList<Object> a=new ArrayList<Object>();

3)使用1.4兼容JDK来编译,javac -source 1.4 Test.java

4)也可以查看警告信息,javac Xlint:unchecked Test.java。这样会显示详细的警告信息

 

转自:http://blog.163.com/zxl06_3/blog/static/30459975200711289232904/